[lively-kernel] Code reorganization in Webwerkstatt - please check your js files
Keith P. Hodges
keith_hodges at yahoo.co.uk
Thu Oct 27 18:19:04 CEST 2011
I am a bit confused. Having checked ouf "kernel" (I agree it could use a better name), todays update brings with it a "users" directory, and the PartsBin.
Not what I expect for a "kernel".
The naming convention I have used in the past is.
"kernel" for the absolute minimal common core functionality
- In a system like lively-kernel it doesn't have to work
- in a squeak like system, it should be able to run a bootstrap to load core packages, i.e. no UI.
"core" loadable libraries that provide standard functionality on top of "kernel".
"packages" loadable modules to extend base.
"kernel, core and packages" are separate code repositories, where as "base and stable" are assemblies of code from the above repositories.
"release" whatever the developers have thrown at me (in the case of squeak/cuis)
"base" an empty working starting point for building stuff, (is a conceptual or virtual release, i.e. "stable" with unloadable packages taken out.
- effectively the release of "kernel" + "core"
"stable" - a release "base" + default "packages" for end users to work with.
- "stable" = "kernel" + "core" + "packages" x N
- If "packages" are "unloadable" or "load on demand", then a larger "stable" release gives users more to play with, but does not limit flexibility at all.
To support forking, in launchpad the same naming convention can be used for different products..
So my own product would be
More information about the lively-kernel